using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[(\&&?)]?([^=]+)(==|!=|>=|<=)([^&#]+)(&&|\|\|)?";
string input = @"BuilderPromo.builder_id==6&&request.id==6";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}