import Foundation
let pattern = #"^(0[1-9]|1\d|2[1-8]|29(?=-\d\d-(?!1[01345789]00|2[1235679]00)\d\d(?:[02468][048]|[13579][26]))|30(?!-02)|31(?=-0[13578]|-1[02]))-(0[1-9]|1[0-2])-([12]\d{3}) ([01]\d|2[0-3]):([0-5]\d):([0-5]\d)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
29-02-1700 15:11:45
29-02-1600 15:11:45
29-02-1604 15:11:45
29-02-2001 15:11:45
31-01-2000 15:11:45
30-02-2000 15:11:45
29-02-2004 15:11:45
31-02-2000 15:11:45
31-12-2000 15:11:45
31-06-2000 15:11:45
15-02-2000 15:11:45
29-02-2002 15:11:45
29-02-2004 15:11:45
29-02-1800 15:11:45
29-02-2000 15:11:45
29-02-1900 15:11:45
28-02-2000 15:11:45
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}