const regex = /^(0[1-9]|1\d|2[1-8]|29(?=-\d\d-(?!1[01345789]00|2[1235679]00)\d\d(?:[02468][048]|[13579][26]))|30(?!-02)|31(?=-0[13578]|-1[02]))-(0[1-9]|1[0-2])-([12]\d{3}) ([01]\d|2[0-3]):([0-5]\d):([0-5]\d)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(0[1-9]|1\\d|2[1-8]|29(?=-\\d\\d-(?!1[01345789]00|2[1235679]00)\\d\\d(?:[02468][048]|[13579][26]))|30(?!-02)|31(?=-0[13578]|-1[02]))-(0[1-9]|1[0-2])-([12]\\d{3}) ([01]\\d|2[0-3]):([0-5]\\d):([0-5]\\d)$', '')
const str = `29-02-1700 15:11:45
29-02-1600 15:11:45
29-02-1604 15:11:45
29-02-2001 15:11:45
31-01-2000 15:11:45
30-02-2000 15:11:45
29-02-2004 15:11:45
31-02-2000 15:11:45
31-12-2000 15:11:45
31-06-2000 15:11:45
15-02-2000 15:11:45
29-02-2002 15:11:45
29-02-2004 15:11:45
29-02-1800 15:11:45
29-02-2000 15:11:45
29-02-1900 15:11:45
28-02-2000 15:11:45`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}