import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\()|(?:(([udfblrmesxyz])(?:([-i'])|(2))?)|(\\[((?:(?:[ud][fb]|[fb][ud])(?:[lr]?)|(?:[fb][lr]|[lr][fb])(?:[ud]?)|(?:[ud][lr]|[lr][ud])(?:[fb]?))|(?:o[24][udfb]|o6[lr]|c[cw][23]|pt[jn]|par|prn))]))|(\\)([1-9min'])?)";
final String string = "face rotations: fblrudf'b'l'r'u'd'fibiliriuidi\n"
+ "axis rotations: xyzx'y'z'xiyizi\n"
+ "pieces: [uf][ub][df][db][fu][bu][fd][bd][fl][fr][bl][br][lf][rf][lb][rb][ur][ul][dr][dl][ru][lu][rd][ld][urf][ufr]...\n"
+ "patterns: [o2u][o2f]...[o4d][o4b]...[o6l][o6r][cc2][cc3][cw2][cw3][par][ptn][ptj][prn]\n"
+ "groups: (rf) (rf)'(rf)n (rf)i (rf)m (rf)3\n\n"
+ "mixed (and test):\n"
+ "[f'r-abix2]\n"
+ "[r2u]\n"
+ "(r(fr)i[FR])m f";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}