$re = '/<span .+?(?=>)>/';
$str = '<span style="color: #0000ff">public</span> <span style="color: #0000ff">class</span>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);