using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<span .+?(?=>)>";
string input = @"<span style=""color: #0000ff"">public</span> <span style=""color: #0000ff"">class</span>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}