$re = '/^(?P<start>.*)\s(-|to)\s(?P<end>.*)$/is';
$str = '18/03/1989 to 19/10/2000';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);