package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)^(?P<start>.*)\s(-|to)\s(?P<end>.*)$`)
var str = `18/03/1989 to 19/10/2000`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}