re = /^\d{11}/
str = '1100582367|SDFDSFDSFDSFDSFDF
GBC213WREW|RWEFSDFSDF
1100582377|DSFDSFDSFDSF
2NDG.S.D
BIKADSFDSFDSFNO.421
1100582387|SDFSDFSDFDSF'
# Print the match result
str.match(re) do |match|
puts match.to_s
end