$re = '/^\d{11}/';
$str = '1100582367|SDFDSFDSFDSFDSFDF
GBC213WREW|RWEFSDFSDF
1100582377|DSFDSFDSFDSF
2NDG.S.D
BIKADSFDSFDSFNO.421
1100582387|SDFSDFSDFDSF';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);