// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((http|https)(\:\/\/)((([a-zA-Z_\-0-9]{1,2000})(\.)([a-zA-Z_\-0-9]{1,2000})(\.)([a-zA-Z_\-0-9]{1,16}))|(([a-zA-Z_\-0-9]{1,2000})(\.)([a-zA-Z_\-0-9]{1,16})))((([\/a-zA-Z\ _\-%0-9\.\?\=]{1,3000})|(\/)|())))").unwrap();
let string = "https://timmyrs.de";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}