const regex = /((http|https)(\:\/\/)((([a-zA-Z_\-0-9]{1,2000})(\.)([a-zA-Z_\-0-9]{1,2000})(\.)([a-zA-Z_\-0-9]{1,16}))|(([a-zA-Z_\-0-9]{1,2000})(\.)([a-zA-Z_\-0-9]{1,16})))((([\/a-zA-Z\ _\-%0-9\.\?\=]{1,3000})|(\/)|())))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((http|https)(\\:\\\/\\\/)((([a-zA-Z_\\-0-9]{1,2000})(\\.)([a-zA-Z_\\-0-9]{1,2000})(\\.)([a-zA-Z_\\-0-9]{1,16}))|(([a-zA-Z_\\-0-9]{1,2000})(\\.)([a-zA-Z_\\-0-9]{1,16})))((([\\\/a-zA-Z\\ _\\-%0-9\\.\\?\\=]{1,3000})|(\\\/)|())))', '')
const str = `https://timmyrs.de`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}