re = /(\/\d+)/
str = 'http://localhost:3000/aptitude/static/catalog.html#/category/1699303855/list'
# Print the match result
str.match(re) do |match|
puts match.to_s
end