$re = '/(\/\d+)/';
$str = 'http://localhost:3000/aptitude/static/catalog.html#/category/1699303855/list';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);