re = /^((?:[A-Za-z0-9+]+)(?:[._-]{1}[A-Za-z]+)*)([._-]{1}(?:[+-_\dA-Za-z.]*)*)*$/m
str = 'AbCd_V13.1.6_WIN32_X64
Efgh-1.28.1
IjKl400f-ABC-_0_1_1
mno_pqr_2002.07.03_16.29h_ab
stuv_2003.02.05_14.06h_WX_Yzab
ef-ghij-klmn-op-5.12.1-qrst-uvw
Xyzab
Defgh_1_11_0
Ijkl_mno_20100319_115358
Pqrs1679_0_1_5
tuvw++_2008.12.02_09.56h_ghe
xyz_abcd_19_3
efgh3.5.12_200603
ijkl-windows10-ver11x2_0-1.0.0
mnop-windows10_11x2ijkl-ver8.1.0.77-1.0.0
Qrst-UvWx-2.0.3+YzAbcd3.4.7
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end