#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?:[A-Za-z0-9+]+)(?:[._-]{1}[A-Za-z]+)*)([._-]{1}(?:[+-_\dA-Za-z.]*)*)*$"
Local $sString = "AbCd_V13.1.6_WIN32_X64" & @CRLF & _
"Efgh-1.28.1" & @CRLF & _
"IjKl400f-ABC-_0_1_1" & @CRLF & _
"mno_pqr_2002.07.03_16.29h_ab" & @CRLF & _
"stuv_2003.02.05_14.06h_WX_Yzab" & @CRLF & _
"ef-ghij-klmn-op-5.12.1-qrst-uvw" & @CRLF & _
"Xyzab" & @CRLF & _
"Defgh_1_11_0" & @CRLF & _
"Ijkl_mno_20100319_115358" & @CRLF & _
"Pqrs1679_0_1_5" & @CRLF & _
"tuvw++_2008.12.02_09.56h_ghe" & @CRLF & _
"xyz_abcd_19_3" & @CRLF & _
"efgh3.5.12_200603" & @CRLF & _
"ijkl-windows10-ver11x2_0-1.0.0" & @CRLF & _
"mnop-windows10_11x2ijkl-ver8.1.0.77-1.0.0" & @CRLF & _
"Qrst-UvWx-2.0.3+YzAbcd3.4.7" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")