$re = '/^([0-3]{1}?[0-9]{1})(\/|-)([0-1]{1}?[0-9]{1})(\/|-)([1-2]{1}[0-9]{3})( |-| - )([1-9]{1}[0-9]{1}|[0-2]{1}[0-9]{1}):([0-5]{1}?[0-9]{1}):([0-5]{1}?[0-9]{1})$/mi';
$str = '13/08/2015 15:07:01
13/08/2015-15:07:01
13/08/2015 - 15:07:01
01/01/2015 - 11:00:00
01/01/2015 - 22:10:55';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);