#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^([0-3]{1}?[0-9]{1})(\/|-)([0-1]{1}?[0-9]{1})(\/|-)([1-2]{1}[0-9]{3})( |-| - )([1-9]{1}[0-9]{1}|[0-2]{1}[0-9]{1}):([0-5]{1}?[0-9]{1}):([0-5]{1}?[0-9]{1})$"
Local $sString = "13/08/2015 15:07:01" & @CRLF & _
"13/08/2015-15:07:01" & @CRLF & _
"13/08/2015 - 15:07:01" & @CRLF & _
"01/01/2015 - 11:00:00" & @CRLF & _
"01/01/2015 - 22:10:55"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")