use strict;
my $str = 'L_SAMBIL
+++ L_SAMBIL 2020-09-21 11:53:53
O&M #1502
%%/*1882154167*/LST ALMLOG:ALMTP=all,CLRFLG=cleared-1&uncleared-1,CLRSD=2020&09&21,CLRED=2020&09&22,STARTAID=29240,ENDAID=29240;%%
RETCODE = 0 Operation succeeded
ALARM 72712 Fault Major eNodeB 29240 Signaling
Sync serial No. = 162656
Alarm name = Cell Unavailable
Alarm raised time = 2020-09-21 06:36:19
Location info = Local Cell ID=2, Cell FDD TDD indication=FDD, NB-IoT Cell Flag=FALSE, Cell Name=L_SAMBIL2, eNodeB ID=15080, Cell ID=2, Specific Problem=External link fault
Function = eNodeB Function Name=L_SAMBIL, objId=0
Cleared type = Normally cleared
Cleared time = 2020-09-21 06:39:42
Special info = RAT_INFO=L, AFFECTED_RAT=L, DID=NULL
Special info1 = AF_L=L_SAMBIL
ALARM 72713 Fault Major eNodeB 29240 Signaling
Sync serial No. = 162655
Alarm name = Cell Unavailable
Alarm raised time = 2020-09-21 06:36:19
Location info = Local Cell ID=3, Cell FDD TDD indication=FDD, NB-IoT Cell Flag=FALSE, Cell Name=L_SAMBIL3, eNodeB ID=15080, Cell ID=3, Specific Problem=External link fault
Function = eNodeB Function Name=L_SAMBIL, objId=0
Cleared type = Normally cleared
Cleared time = 2020-09-21 06:39:41
Special info = RAT_INFO=L, AFFECTED_RAT=L, DID=NULL
Special info1 = AF_L=L_SAMBIL
ALARM 72711 Fault Major eNodeB 29240 Signaling
Sync serial No. = 162654
Alarm name = Cell Unavailable
Alarm raised time = 2020-09-21 06:36:19
Location info = Local Cell ID=1, Cell FDD TDD indication=FDD, NB-IoT Cell Flag=FALSE, Cell Name=L_SAMBIL1, eNodeB ID=15080, Cell ID=1, Specific Problem=External link fault
Function = eNodeB Function Name=L_SAMBIL, objId=0
Cleared type = Normally cleared
Cleared time = 2020-09-21 06:39:41
Special info = RAT_INFO=L, AFFECTED_RAT=L, DID=NULL
Special info1 = AF_L=L_SAMBIL
(Number of results = 3)
--- END';
my $regex = qr/(?:ALARM[\s]*)(?:\d*)[A-Za-z\s\d\.=]*(?:Alarm\sraised\stime)\s+=\s+([\d\-]+\s[\d\:]+)\s+(?:Location\sinfo)\s+=\s+Local\sCell\sID=([\d]+)(?:,\s[a-zA-Z]+\s[A-Z]+\s[A-Z]+\s[a-zA-Z\=,]+\s[a-zA-Z\=-]+\s[a-zA-Z\=-]+\s[a-zA-Z\=-_,]+)[\s\,A-Za-z0-9=\_]*(?:eNodeB\sID=)([0-9]+)(?:,.+\s\s+.+\s+)(?:Cleared\stype)\s+=\s+([a-zA-Z ]+)(?:[\sA-Za-z\s=]*)([\d-]*\s[\d:]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}