const regex = new RegExp('(?:ALARM[\\s]*)(?:\\d*)[A-Za-z\\s\\d\\.=]*(?:Alarm\\sraised\\stime)\\s+=\\s+([\\d\\-]+\\s[\\d\\:]+)\\s+(?:Location\\sinfo)\\s+=\\s+Local\\sCell\\sID=([\\d]+)(?:,\\s[a-zA-Z]+\\s[A-Z]+\\s[A-Z]+\\s[a-zA-Z\\=,]+\\s[a-zA-Z\\=-]+\\s[a-zA-Z\\=-]+\\s[a-zA-Z\\=-_,]+)[\\s\\,A-Za-z0-9=\\_]*(?:eNodeB\\sID=)([0-9]+)(?:,.+\\s\\s+.+\\s+)(?:Cleared\\stype)\\s+=\\s+([a-zA-Z ]+)(?:[\\sA-Za-z\\s=]*)([\\d-]*\\s[\\d:]+)', 'gm')
const str = `L_SAMBIL
+++ L_SAMBIL 2020-09-21 11:53:53
O&M #1502
%%/*1882154167*/LST ALMLOG:ALMTP=all,CLRFLG=cleared-1&uncleared-1,CLRSD=2020&09&21,CLRED=2020&09&22,STARTAID=29240,ENDAID=29240;%%
RETCODE = 0 Operation succeeded
ALARM 72712 Fault Major eNodeB 29240 Signaling
Sync serial No. = 162656
Alarm name = Cell Unavailable
Alarm raised time = 2020-09-21 06:36:19
Location info = Local Cell ID=2, Cell FDD TDD indication=FDD, NB-IoT Cell Flag=FALSE, Cell Name=L_SAMBIL2, eNodeB ID=15080, Cell ID=2, Specific Problem=External link fault
Function = eNodeB Function Name=L_SAMBIL, objId=0
Cleared type = Normally cleared
Cleared time = 2020-09-21 06:39:42
Special info = RAT_INFO=L, AFFECTED_RAT=L, DID=NULL
Special info1 = AF_L=L_SAMBIL
ALARM 72713 Fault Major eNodeB 29240 Signaling
Sync serial No. = 162655
Alarm name = Cell Unavailable
Alarm raised time = 2020-09-21 06:36:19
Location info = Local Cell ID=3, Cell FDD TDD indication=FDD, NB-IoT Cell Flag=FALSE, Cell Name=L_SAMBIL3, eNodeB ID=15080, Cell ID=3, Specific Problem=External link fault
Function = eNodeB Function Name=L_SAMBIL, objId=0
Cleared type = Normally cleared
Cleared time = 2020-09-21 06:39:41
Special info = RAT_INFO=L, AFFECTED_RAT=L, DID=NULL
Special info1 = AF_L=L_SAMBIL
ALARM 72711 Fault Major eNodeB 29240 Signaling
Sync serial No. = 162654
Alarm name = Cell Unavailable
Alarm raised time = 2020-09-21 06:36:19
Location info = Local Cell ID=1, Cell FDD TDD indication=FDD, NB-IoT Cell Flag=FALSE, Cell Name=L_SAMBIL1, eNodeB ID=15080, Cell ID=1, Specific Problem=External link fault
Function = eNodeB Function Name=L_SAMBIL, objId=0
Cleared type = Normally cleared
Cleared time = 2020-09-21 06:39:41
Special info = RAT_INFO=L, AFFECTED_RAT=L, DID=NULL
Special info1 = AF_L=L_SAMBIL
(Number of results = 3)
--- END`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}