re = /(?<=\G(?!^)|clients_field_)(\w*)-/
str = '"clients_field_4741a6c5-3855-4455-b487-0b38b0038ae6": "info@domain.com",
"clients_field_78f225e0-1a78-4930-b251-ad2217baeb1b": "2017-07-26"'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result