using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\G(?!^)|clients_field_)(\w*)-";
string substitution = @"$1";
string input = @"""clients_field_4741a6c5-3855-4455-b487-0b38b0038ae6"": ""info@domain.com"",
""clients_field_78f225e0-1a78-4930-b251-ad2217baeb1b"": ""2017-07-26""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}