const regex = /(\r|\n| |\t)+\<Grid(\r|\n| |\t)+Grid\.Row="0"(\r|\n| |\t)+IsVisible="False"(\r|\n| |\t)+Style="\{StaticResource(\r|\n| |\t)+MadressahFilterPickerGridBackgroundStyle\}"\>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\r|\\n| |\\t)+\\<Grid(\\r|\\n| |\\t)+Grid\\.Row="0"(\\r|\\n| |\\t)+IsVisible="False"(\\r|\\n| |\\t)+Style="\\{StaticResource(\\r|\\n| |\\t)+MadressahFilterPickerGridBackgroundStyle\\}"\\>', 'g')
const str = ` <Grid Grid.Row="2" Grid.Column="2" RowSpacing="0">
<Grid.RowDefinitions>
<RowDefinition Height="Auto" />
</Grid.RowDefinitions>
<Grid Grid.Row="0" Style="{StaticResource MadressahFilterPickerGridBackgroundStyle}">
<StackLayout Orientation="Horizontal">
<StackLayout.GestureRecognizers>
<TapGestureRecognizer Tapped="ParentTapGestureRecognizer_Tapped" />
</StackLayout.GestureRecognizers>
<Label x:Name="parentName" Text="{Binding ParentPicker}"
BindingContext="{ Binding Source={x:Reference Root}, Path=BindingContext}"
Style="{StaticResource MadressahFilterPickerLabelStyle}" LineBreakMode="NoWrap"/>
<Label Style="{StaticResource MadressahPickerArrowStyle}" />
</StackLayout>
</Grid>
<Grid Grid.Row="0" IsVisible="False"
Style="{StaticResource MadressahFilterPickerGridBackgroundStyle}">
<Picker x:Name="parentList" Title="{i18n:Translate selectparent}"
ItemsSource="{Binding ParentList}"
ItemDisplayBinding="{Binding FullName}"
SelectedItem="{Binding ParentSelected}"
BindingContext="{ Binding Source={x:Reference Root}, Path=BindingContext}" />
</Grid>
</Grid>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}