import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\r|\\n| |\\t)+\\<Grid(\\r|\\n| |\\t)+Grid\\.Row=\"0\"(\\r|\\n| |\\t)+IsVisible=\"False\"(\\r|\\n| |\\t)+Style=\"\\{StaticResource(\\r|\\n| |\\t)+MadressahFilterPickerGridBackgroundStyle\\}\"\\>";
final String string = " <Grid Grid.Row=\"2\" Grid.Column=\"2\" RowSpacing=\"0\">\n"
+ " <Grid.RowDefinitions>\n"
+ " <RowDefinition Height=\"Auto\" />\n"
+ " </Grid.RowDefinitions>\n"
+ " <Grid Grid.Row=\"0\" Style=\"{StaticResource MadressahFilterPickerGridBackgroundStyle}\">\n"
+ " <StackLayout Orientation=\"Horizontal\">\n"
+ " <StackLayout.GestureRecognizers>\n"
+ " <TapGestureRecognizer Tapped=\"ParentTapGestureRecognizer_Tapped\" />\n"
+ " </StackLayout.GestureRecognizers>\n"
+ " <Label x:Name=\"parentName\" Text=\"{Binding ParentPicker}\"\n"
+ " BindingContext=\"{ Binding Source={x:Reference Root}, Path=BindingContext}\"\n"
+ " Style=\"{StaticResource MadressahFilterPickerLabelStyle}\" LineBreakMode=\"NoWrap\"/>\n"
+ " <Label Style=\"{StaticResource MadressahPickerArrowStyle}\" />\n"
+ " </StackLayout>\n"
+ " </Grid>\n"
+ " <Grid Grid.Row=\"0\" IsVisible=\"False\"\n"
+ " Style=\"{StaticResource MadressahFilterPickerGridBackgroundStyle}\">\n"
+ " <Picker x:Name=\"parentList\" Title=\"{i18n:Translate selectparent}\"\n"
+ " ItemsSource=\"{Binding ParentList}\"\n"
+ " ItemDisplayBinding=\"{Binding FullName}\"\n"
+ " SelectedItem=\"{Binding ParentSelected}\"\n"
+ " BindingContext=\"{ Binding Source={x:Reference Root}, Path=BindingContext}\" />\n"
+ " </Grid>\n"
+ " </Grid>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}