import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\s*\\{\\s*#\\s*(?<operator>endcase|endswitch|endfor|endif|if|elif|else|for|switch|case|default)\\s*(?<args>[^\\}]*)\\s*\\}\\s*\\}\\s*(?<body>[^\\{]*(?:\\s*\\{\\s*\\{\\s*#\\s*(?!(?&operator))\\s*[^\\}]*\\s*\\}\\s*\\}\\s*[^\\{]*)*)";
final String string = "<div>\n"
+ "{{#if arg1.arg2}}\n"
+ "<span>{{#var arg3 static}}</span>\n"
+ "blablabla{{#for k, v in arg4}}\n"
+ "<p>{{#var k}}<span>{{#var v.arg5}}</span></p>\n"
+ "{{#if (k == \"test\" or v != 0) and k == 0}}\n"
+ "<span></span>\n"
+ "{{#elif k == 0}}\n"
+ "<p></p>\n"
+ "{{#else}}\n"
+ "<div></div>\n"
+ "{{#endif}}\n"
+ "{{#endfor}}\n"
+ "{{#endif}}\n\n"
+ "{{#switch arg6}}\n"
+ "{{#case 5}}\n"
+ "case 5\n"
+ "{{#case 6, 7, 8}}\n"
+ "case 6, 7, 8\n"
+ "{{#endcase}}\n"
+ "{{#default}}\n"
+ "def\n"
+ "{{#endcase}}\n"
+ "{{#endswitch}}\n\n"
+ "{{#for i as 0, 5}}\n"
+ "test i\n"
+ "{{#endfor}}";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}