use strict;
my $str = '__nls__Cancellation permitted 03 Hrs before scheduled departure __nls__ Within 03-72 hrs INR 3,500 or 100% of airfare charge (whichever is lower) __nls__ Before 72 hrs INR 3,000 or 100% of airfare charge (whichever is lower)';
my $regex = qr/(__nls__)(.*?)(INR)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}