import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(__nls__)(.*?)(INR)";
final String string = "__nls__Cancellation permitted 03 Hrs before scheduled departure __nls__ Within 03-72 hrs INR 3,500 or 100% of airfare charge (whichever is lower) __nls__ Before 72 hrs INR 3,000 or 100% of airfare charge (whichever is lower)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}