$re = '/(\d+)\.(\d+)(?:\.(\d+))?(?:\-(\w+))?/i';
$str = '1.2-SNAP';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);