const regex = /(\d+)\.(\d+)(?:\.(\d+))?(?:\-(\w+))?/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)\\.(\\d+)(?:\\.(\\d+))?(?:\\-(\\w+))?', 'i')
const str = `1.2-SNAP`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}