use strict;
my $str = '/* UACK */ {CAN_SID_UACK_IDT1S03, CAN_SID_N_UACK_0_IDT1S03}, /* blah blah blah */
{RSTART_';
my $regex = qr/[\/\*A-Z0-9_\s]*(?=\{)\{CAN_SID[A-Z0-9_]+(?=(_([A-Z0-9]{6}[0-9]))).+(?=(CAN_SID[A-Z0-9_]+(?=(_([A-Z0-9]{6}[0-9])))))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}