re = /^0([1-9]{2})([1-9]{2})([2-3]{1})([0-9]{3})([0-9]{4})$|([1-9]{2})([2-3]{1})([0-9]{3})([0-9]{4})$/
str = '0157436211982'
# Print the match result
str.match(re) do |match|
puts match.to_s
end