use strict;
my $str = '0157436211982';
my $regex = qr/^0([1-9]{2})([1-9]{2})([2-3]{1})([0-9]{3})([0-9]{4})$|([1-9]{2})([2-3]{1})([0-9]{3})([0-9]{4})$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}