re = /\$([\S]+)\b/
str = 'Local $residents o1__have called g__in o22__with reports...,u
Local ,residents o1__have called g__in o22__with reports...$u
Local ,residents o1__have called g__in o22__with reports...,u
Local ,residents o1__have called g__in o22__with reports...,u
Local $residents o1__have called g__in o22__with reports...,u
Local ,residents o1__have called g__in o22__with reports...$u
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end