package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\$([\S]+)\b`)
var str = `Local $residents o1__have called g__in o22__with reports...,u
Local ,residents o1__have called g__in o22__with reports...$u
Local ,residents o1__have called g__in o22__with reports...,u
Local ,residents o1__have called g__in o22__with reports...,u
Local $residents o1__have called g__in o22__with reports...,u
Local ,residents o1__have called g__in o22__with reports...$u
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}