import Foundation
let pattern = #"((?=ra\/[0-9]{4}\/[0-9]+\/[0-9]{2}\/[0-9]+\/\Qimage(2).jpg\E).+$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"http://localhost:8080/ra/2015/10160/11/115500/image(2).jpg""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}