import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?=ra\\/[0-9]{4}\\/[0-9]+\\/[0-9]{2}\\/[0-9]+\\/\\Qimage(2).jpg\\E).+$)";
final String string = "http://localhost:8080/ra/2015/10160/11/115500/image(2).jpg\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}