$re = '/\s{2,}/m';
$str = ' some tring with sapce nm more space 5 now end. .';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;