package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s{2,}`)
var str = ` some tring with sapce nm more space 5 now end. .`
var substitution = " "
fmt.Println(re.ReplaceAllString(str, substitution))
}