re = /(\d+)\.(\d+)\.(\d+) (\d+):(\d+):(\d+)/
str = 'foo 24.03.2014 19:18:57 foobar foo bar
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end