package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+)\.(\d+)\.(\d+) (\d+):(\d+):(\d+)`)
var str = `foo 24.03.2014 19:18:57 foobar foo bar
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}