import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(http(s)?:\\/\\/)?([\\w]+\\.)?linkedin\\.com\\/(pub|in|profile)";
final String string = "es.linkedin.com/pub/francisco-fernandez/30/14/62\n"
+ "https://www.linkedin.com/profile/view?id=107523146&authType=name&authToken=A2nj&trk=nmp_pymk_name\n"
+ "de.linkedin.com/pub/frank-rempp/1/638/7a1\n"
+ "http://uk.linkedin.com/pub/some-name/1/1b3/b45/\n"
+ "http://nl.linkedin.com/pub/other-name/11/223/544\n"
+ "http://www.linkedin.com/in/aname/\n"
+ "http://www.linkedin.com/in/another-name\n"
+ "http://linkedin.com/in/name\n"
+ "http://nl.linkedin.com/in/name\n"
+ "http://nl.linkedin.com/in/name/";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}