package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(http(s)?:\/\/)?([\w]+\.)?linkedin\.com\/(pub|in|profile)`)
var str = `es.linkedin.com/pub/francisco-fernandez/30/14/62
https://www.linkedin.com/profile/view?id=107523146&authType=name&authToken=A2nj&trk=nmp_pymk_name
de.linkedin.com/pub/frank-rempp/1/638/7a1
http://uk.linkedin.com/pub/some-name/1/1b3/b45/
http://nl.linkedin.com/pub/other-name/11/223/544
http://www.linkedin.com/in/aname/
http://www.linkedin.com/in/another-name
http://linkedin.com/in/name
http://nl.linkedin.com/in/name
http://nl.linkedin.com/in/name/`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}