import Foundation
let pattern = #"([^\s]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = ##"""
@JoonasJQWÜPKEQÖW:DQ_D:QWÄ!"_©@©©@¶©”#¶¶©£ l.
on sitaks @tore poiss @kesdfasf haiseb@mail.ee või jaakpeldes @gmail.com
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}