const regex = /([^\s]+)/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\\s]+)', 'i')
const str = `@JoonasJQWÜPKEQÖW:DQ_D:QWÄ!"_©@©©@¶©”#¶¶©£ l.
on sitaks @tore poiss @kesdfasf haiseb@mail.ee või jaakpeldes @gmail.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}