re = /([0-9]|[a-zA-Z]+)*/
str = 'maisexemplos123478testemuito6mais4significativos'
# Print the match result
str.match(re) do |match|
puts match.to_s
end