$re = '/([0-9]|[a-zA-Z]+)*/';
$str = 'maisexemplos123478testemuito6mais4significativos';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);