import Foundation
let pattern = #"(([A-Z][a-z]*(\s))([a-z]*(\s))*([a-z]+)[.])*(?!([A-z0-9]*(\s)))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Theqwererwerwewe qwe ertret asdf.Rtrt ewe."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}