using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(([A-Z][a-z]*(\s))([a-z]*(\s))*([a-z]+)[.])*(?!([A-z0-9]*(\s)))";
string input = @"Theqwererwerwewe qwe ertret asdf.Rtrt ewe.";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}