const regex = /^.*?\b(?!www\.)((?:[\w-]+\.)+[\w-]+).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*?\\b(?!www\\.)((?:[\\w-]+\\.)+[\\w-]+).*$', 'gm')
const str = `http://nike-admin.app.com
google.com
www.google.com
ftp://ftp.google.com
http://www.google.com
http://www.google.com/
https://www.google.com/
https://www.google.com.sg/
http://app.com
http://www.app.com`;
const subst = `https://$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);