#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^.*?\b(?!www\.)((?:[\w-]+\.)+[\w-]+).*$"
Local $sString = "http://nike-admin.app.com" & @CRLF & _
"google.com" & @CRLF & _
"www.google.com" & @CRLF & _
"ftp://ftp.google.com" & @CRLF & _
"http://www.google.com" & @CRLF & _
"http://www.google.com/" & @CRLF & _
"https://www.google.com/" & @CRLF & _
"https://www.google.com.sg/" & @CRLF & _
"http://app.com" & @CRLF & _
"http://www.app.com"
Local $sSubst = "https://$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)